5 trucchi per diventare vero esperto di Excel

Excel
Excel

Excel è indubbiamente il più potente strumento per la raccolta e la manipolazione dei dati attualmente disponibili sul mercato. In ambito contabile, i fogli di calcolo Excel sono uno strumento quotidiano utilizzato per analizzare i dati finanziari, esaminare l'andamento delle vendite, verificare il cash flow aziendale o fare un business plan. Più si conoscono le funzionalità di Excel, più le attività d'ufficio diventano semplici. Ecco, quindi, 5 facili trucchi per diventare un vero esperto di Excel.

1 – Riferimenti assoluti e relativi

Uno degli aspetti di fondamentale importanza di Excel è quello di estrarre dati da un'altra cella. Ad esempio, se vogliamo copiare il contenuto della cella C1 all'interno della cella F4 è sufficiente posizionarsi su quest'ultima cella e inserire la formula

=C1

Excel

La formula così impostata viene definita riferimento relativo. Ciò vuol dire che si modifica automaticamente quando si copia e si incolla in altre celle. Infatti, copiando la formula della cella F4 e incollandola nella cella F5 si noterà come la formula assuma automaticamente il contenuto di “=C2”.
Nell'esempio proposto, tuttavia, il prezzo unitario è sempre quello riportato nella cella C1. Per ottenere ciò occorre fare in modo che il riferimento alla cella non sia più relativo ma assoluto ossia deve sempre puntare ad una specifica cella.
Per ottenere ciò occorre mettere davanti alla lettera C e al numero 1 il simbolo $ (dollaro). In questo modo la formula definitiva sarà

=$C$1

Un modo rapido per farlo è posizionare il cursore del mouse sulla barra della formula e premere il pulsante F4.

Dal libro Excel. Formule e funzioni For Dummies di Kenn Bluttman

Se prevedete di utilizzare la stessa formula per più celle, per esempio all'interno di una colonna, il metodo migliore consiste nello scrivere la formula una volta e poi replicarla sulle altre celle utilizzando la maniglia di riempimento. Il problema è che quando trascinate una formula in altre posizioni, tutti i riferimenti relativi cambiano.
Spesso questo è proprio quello che desideriamo. Quando abbiamo una colonna di dati e, a fianco, una colonna di formule, in genere vogliamo che ogni formula faccia riferimento al valore che sta esattamente al suo fianco. Ma se le formule devono fare riferimento a una specifica cella non adiacente, normalmente è necessario che tale riferimento sia assoluto.
Per utilizzare un riferimento assoluto in una cella, ponete il segno di dollaro ($) prima del numero, della lettera o di entrambi.

2 – Combina le celle con una e commerciale (&)

In alcuni casi è necessario che il contenuto di due celle sia combinato in una cella unica. Ad esempio si potrebbe avere una colonna per il nome ed un'altra per il cognome ma, in base alle nostre esigenze, è necessario che tali dati siano contenuti in una sola cella in modo da avere le generalità complete. In tal caso, il simbolo & (e commerciale) offre un valido aiuto.
Se, ad esempio, la cella D2 contiene il nome e la cella E2 contiene il cognome, è possibile ottenere il nome e il cognome nella cella F2 digitando la seguente formula:

=D2&" "&E2

Una cosa da notare è che quando il foglio di calcolo combina le celle, se non si hanno spazi dopo ogni parola è necessario aggiungerli alla formula.

Excel

Dal libro Analisi dei dati con Excel 2013 di Paolo Poli

In Excel, la concatenazione impiega il simbolo di "e commerciale" (&). La concatenazione unisce il contenuto di due o più celle. Per esempio, se la cella A1 contiene il testo "Venezia" e la cella A2 contiene il testo "Veneto", la seguente formula restituirà "VeneziaVeneto":

=A1&A2

Ancora meglio, potete interporre una virgola e uno spazio, per generare il risultato "Venezia, Veneto":

=A1&", "A2

Per far sì che la seconda stringa venga collocata a capo, su una nuova riga, concatenate le stringhe interponendo il simbolo speciale CODICE.CARATT(10), il codice di interruzione di riga. Alla cella dovete però applicare il formato Testo a capo. Il seguente esempio unisce il testo contenuto nella cella A1 e il testo contenuto nella cella B1, inserendo però un'interruzione forzata di riga:

=A1&CODICE.CARATT(10)&B1

3 – Formattazione condizionale

Excel consente di creare celle con un determinato colore in base al contenuto della cella. Ciò può essere particolarmente utile quando si lavora con un file di grandi dimensioni: le celle evidenziate con colori diversi consentono di visualizzare più velocemente i dati.
Ad esempio, ipotizzando di avere una tabella con i costi a budget e a consuntivo, si riuscirà a evidenziare solamente le celle in cui il consuntivo è maggiore del budget.

Excel

Nel caso in commento, dopo aver selezionato i dati ho richiamato la funzione Formattazione condizionale dalla scheda Home, quindi ho impostato, fra le regole di evidenziazione celle, quelle che risultano avere un valore minore di zero.

Dal libro Excel 2016 Espresso for Dummies di Greg Harvey

Uno dei modi più rapidi per applicare una formattazione condizionale che si basa su barre di dati, scale di colori, set di icone, valori maggiori o minori o "i primi 10" a una tabella di dati, consiste nell'utilizzare lo strumento Analisi rapida. L'aspetto più interessante di questa modalità di applicazione della formattazione condizionale è il fatto che l'anteprima consente di visualizzare l'aspetto dei dati dopo aver applicato la formattazione condizionale, prima ancora di applicarla.
Per assegnare la formattazione condizionale utilizzando lo strumento Analisi rapida, dovete innanzitutto selezionare i dati contenuti nella tabella che intendete formattare e poi selezionare lo strumento Analisi rapida. Per impostazione predefinita, si aprirà la scheda Formattazione: non dovete fare altro che evidenziare le varie opzioni con il mouse per osservare l'aspetto dei dati.

Per ulteriori approfondimenti sulla formattazione condizionale rimando alla lettura dell'articolo Formattazione condizionale con Excel.

4 – Funzione CERCA.VERT per trovare dati specifici

La funzione CERCA.VERT è una delle funzionalità più potenti di Excel. Si tratta di una funzione in grado di cercare in una grande tabella di dati, il valore corrispondente ad un dato inserito. In pratica, si inserisce nella funzione il testo da cercare e, quando Excel lo trova, restituisce il valore contenuto in una specifica colonna a destra.
Richiamando l'esempio precedente, possiamo estrapolare il valore di budget corrispondente alla tipologia di spesa denominata Informatica. In tal caso la formula da inserire è la seguente:

=CERCA.VERT("Informatica";B5:E11;2;"Falso")

Excel

La funzione CERCA.VERT richiede l'inserimento di quattro campi:

  1. Valore: il valore da cercare (detto anche valore di ricerca);
  2. Matrice_tabella: l'intervallo che contiene il valore di ricerca (il valore di ricerca deve necessariamente trovarsi nella prima colonna dell'intervallo affinché CERCA.VERT funzioni correttamente);
  3. Indice: il numero di colonna nell'intervallo che contiene il valore restituito;
  4. Intervallo: valore opzionale; indicare VERO se si vuole ottenere una corrispondenza approssimativa o FALSO se si vuole ottenere una corrispondenza esatta del valore restituito.

Dal libro Come imparare Excel in 7 giorni: metodo veloce e divertente! di Gordon J. Bright

Il CERCA.VERT è un must. Vi si deve letteralmente piantare in testa, nonostante - lo ammetto - non sia una delle formule più facili da spiegare e da memorizzare.
Brevemente, lo scopo di questa funzione è cercare - da sinistra verso destra e in senso verticale - il valore di una cella presente in una colonna corrispondente a un dato di una tabella in cui detta colonna è presente o meno. [...]
La struttura del CERCA.VERT è la seguente:

=CERCA.VERT(valore, matrice_tabella, indice, intervallo)

Il valore è quello che dobbiamo cercare; la matrice_tabella è la tabella dove andremo a cercarlo; l'indice è il luogo in cui si trova il dato corrispondente; l'intervallo definisce il grado di accuratezza della nostra formula: se inseriremo la voce "vero", la ricerca restituirà tutti i valori che somigliano a quello che stiamo cercando, altrimenti (usando "falso") l'esito dell'operazione sarà univoco.

Per approfondire le modalità di utilizzo della funzione CERCA.VERT rimando alla lettura dell'articolo Trovare dati duplicati con funzione CERCA.VERT di Excel.

5 – Gestire gli errori

Excel evidenzia gli errori visualizzando determinati simboli quali, ad esempio, #N/A, #RIF, #DIV0! o #VALORE!. Ad esempio, se tentiamo di dividere il numero contenuto in una cella con un testo sarà visualizzato l'errore #VALORE!.
È possibile intercettare e gestire gli errori utilizzando la funzione SE.ERRORE. Con tale funzione, Excel restituirà un valore se l'espressione genera un errore; in caso contrario restituisce il valore dell'espressione stessa.

=SE.ERRORE(B4/C4,0)

Articoli correlati

Tags: 

Aggiungi un commento