Trovare dati duplicati con funzione CERCA.VERT di Excel

Excel
Excel

Può accadere di dover verificare i valori di una tabella Excel al fine di trovare eventuali dati duplicati. Utilizzando la funzione CERCA.VERT riusciremo a risolvere con molta velocità il nostro problema. Questo articolo vuole fornire indicazioni su come usare una delle più importanti funzioni presenti nel foglio elettronico della Microsoft.

La funzione CERCA.VERT cerca un valore nella prima colonna a sinistra di una tabella e restituisce un valore nella stessa riga da una colonna specificata. La sintassi della funzione CERCA.VERT è la seguente:

CERCA.VERT(valore; matrice_tabella; indice; [intervallo])

Vediamo, adesso, di conoscere ciascuno degli argomenti che formano tale funzione:

  • valore: è un valore, sia testuale che numerico, da cercare nella prima colonna della tabella di ricerca. Se l'argomento valore è testuale e l'intervallo è FALSO, possono essere inclusi anche i valori jolly * e ?;
  • matrice_tabella: è l'intervallo all’interno del quale devono essere cercati i valori;
  • indice: è il numero della colonna della tabella dalla quale recuperare il valore corrispondente. Ad esempio: l’indice uguale a 1 restituisce il valore contenuto nella prima colonna della tabella; l’indice uguale a 2 restituisce quello contenuto nella seconda colonna e così via;
  • intervallo: è un argomento facoltativo, può contenere VERO o FALSO. Se è indicato VERO (oppure non è indicato nulla) la funzione restituirà la corrispondenza approssimativa; in caso contrario la funzione restituirà la corrispondenza esatta. Qualora la funzione non riuscisse a trovare nessuna corrispondenza esatta, verrà restituito il messaggio di errore #N/D. Se l'intervallo è VERO (ovvero nei casi in cui sia stato omesso), la prima colonna della tabella di ricerca deve essere in ordine crescente.

Fatte queste premesse vediamo adesso come applicare in pratica la funzione. Supponiamo di avere una tabella contenente un elenco di clienti nella quale sono riportati alcuni valori duplicati. Più nel dettaglio, i dati sono inseriti dalla colonna A1 alla colonna A100. Per trovare i dati duplicati andremo a inserire nella riga 2 della colonna B la seguente formula:

=CERCA.VERT(A2;$A$1:A1;1;0)

A questo punto occorre trascinare la formula fino alla cella A100. Grazie alla funzione CERCA.VERT è facile trovare i valori duplicati. Infatti tutti i valori duplicati saranno riportati nella colonna B. Unico inconveniente di questa funzione è la visualizzazione del messaggio #N/D nel caso non venga trovata alcuna corrispondenza. Tuttavia è possibile eliminare questo fastidioso messaggio utilizzando la funzione ERRORE.TIPO.

Excel è indubbiamente un software molto potente. Con formule e funzioni, infatti, permette di gestire in maniera efficace la contabilità e l'amministrazione delle imprese e degli studi professionali. Suggerisco la lettura di Excel. Formule e funzioni For Dummies, una interessante guida utile a imparare a utilizzare le formule Excel in modo semplice e veloce.

Articoli correlati

Tags: 

Aggiungi un commento